Website running slower than normal.

Minor Incident Web Portal
2022-01-31 09:15 UTC · 4 hours, 3 minutes, 53 seconds

Update

Resolved

We can confirm we have now resolved the issue of the website running slower than normal. Thank you for your understanding.

January 31, 2022 · 13:18 UTC
Investigating

We found an issue with one of the servers which was running on maximum CPU. This is why the web portal was running slower than normal. We have resolved this but there seems to be another issue that we are currently investigating. We will keep you updated. Thank you for your understanding.

January 31, 2022 · 09:46 UTC

← Back