Incident: Platform Outage 09/12/25

Major Incident Web Portal Mobile App’s API Account Integrations Search Function Inbound/Outbound Email service
2025-12-09 16:10 UTC · 39 minutes

Update

Resolved

The incident has been resolved and service is now fully restored. We apologise for any disruption caused and appreciate your patience while we worked to fix the issue. If you’re still experiencing problems, please retry and contact support.

December 9, 2025 · 16:48 UTC
Issue

We’re currently experiencing an outage impacting our services. As a result, you may be unable to access the platform and/or see elevated errors and timeouts.

Our engineers have identified the issue and are actively working to restore service as quickly as possible. We’ll share another update within 20 minutes, or sooner if we have new information.

December 9, 2025 · 16:29 UTC

← Back