Emails Arriving Later Than Usual

Minor Incident Inbound/Outbound Email service
2023-05-12 14:39 UTC · 18 hours, 31 minutes

Update

Resolved

The incident of Emails arriving later than usual has now been resolved. Thank you for your patience while we fixed this issue.

May 13, 2023 · 09:08 UTC
Issue

We are currently experiencing Inbound & Outbound emails being sent later than usual. We are currently investigating this issue and are working on a solution. All your data is safe and emails will be sent as soon as possible. We thank you for your patience and will update you soon.

May 12, 2023 · 14:39 UTC

← Back